Mercado Libre´s Technical issues
Incident Report for Real Trends
Resolved
This incident has been resolved.
Posted Jan 24, 2020 - 13:05 GMT-03:00
Update
We are continuing to investigate this issue.
Posted Jan 24, 2020 - 11:50 GMT-03:00
Investigating
Mercado Libre is experiencing technical issues. We have reported it and they are investigating it.
Posted Jan 24, 2020 - 11:09 GMT-03:00
This incident affected: Real Trends - Lister.