Market issues
Incident Report for Real Trends
Resolved
This incident has been resolved.
Posted Mar 19, 2019 - 10:17 GMT-03:00
Investigating
Oops! We are experiencing issues with Mercado. Our engineering team is working on a solution and we hope to have the problem resolved as soon as possible.
Posted Mar 19, 2019 - 10:10 GMT-03:00
This incident affected: Real Trends - Market.